CVE-2024-3586 PUBLISHED

LetterPress < 2.4.0 - Admin+ Stored XSS

Assigner: WPScan
Reserved: 10.04.2024 Published: 29.10.2026 Updated: 29.10.2026

The LetterPress WordPress plugin before 2.4.0 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Product Status

Vendor Unknown
Product LetterPress
Versions Default: unaffected
  • affected from 0 to 2.4.0 (excl.)

Credits

  • SANU P.L finder
  • WPScan coordinator

References

Problem Types

  • CWE-79 Cross-Site Scripting (XSS) CWE