CVE-2025-15701 PUBLISHED

Easy Social Icons < 4.0.3 - Admin+ Stored XSS via Icon Color Settings

Assigner: WPScan
Reserved: 04.10.2026 Published: 05.11.2026 Updated: 05.11.2026

The Easy Social Icons WordPress plugin before 4.0.3 does not sanitise and escape some of its settings before outputting them on front-end pages, which could allow high-privilege users such as Administrators to perform Stored Cross-Site Scripting attacks when the unfiltered_html capability is disallowed, for example on a multisite network.

Product Status

Vendor Unknown
Product Easy Social Icons
Versions Default: unaffected
  • affected from 0 to 4.0.3 (excl.)

Credits

  • Dmitrii Ignatyev finder
  • WPScan coordinator

References

Problem Types

  • CWE-79 Cross-Site Scripting (XSS) CWE