CVE-2026-103039 PUBLISHED

Gravity Forms <= 3.1.2 - Unauthenticated PHP Object Injection via Post Custom Field

Assigner: Wordfence
Reserved: 29.09.2026 Published: 30.10.2026 Updated: 30.10.2026

The Gravity Forms plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 3.1.2 via a Post Custom Field whose input type is List. This is due to GFFormsModel::create_post() passing the submitted value to WordPress' unrestricted global maybe_unserialize() rather than the plugin's own hardened GFCommon::maybe_unserialize(), which was added in 3.1.1 and passes allowed_classes => false precisely to prevent object instantiation. Where the field has a content template enabled, the submitted row reaches that call verbatim. This makes it possible for unauthenticated attackers to inject a PHP object into post meta. No PHP Object Injection gadget chain is present in the plugin itself; however, if a gadget chain is present via an additional plugin or theme, it could allow the attacker to perform actions such as remote code execution. Where the custom field is mapped to the protected _wp_page_template meta key, WordPress itself supplies the chain: validate_file() accepts non-scalars, WP_Theme::__toString() then resolves an attacker-controlled path, and on hosts with a readable PEAR install and register_argc_argv enabled this yields remote code execution.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS Score: 9.8

Product Status

Vendor Gravity Forms
Product Gravity Forms
Versions Default: unaffected
  • affected from 0 to 3.1.2 (incl.)

Credits

  • Tin Pham (TF1T) finder
  • Hao Ngo finder
  • Trong Pham finder

References

Problem Types

  • CWE-502 Deserialization of Untrusted Data CWE