CVE-2026-104331 PUBLISHED

Langflow OSS is affected by multiple vulnerabilities

Assigner: ibm
Reserved: 01.10.2026 Published: 29.10.2026 Updated: 29.10.2026

IBM Langflow OSS 1.0.0 through 1.12.3 is vulnerable to server-side request forgery (SSRF). This may allow an authenticated attacker to send unauthorized requests from the system, potentially leading to network enumeration or facilitating other attacks.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
CVSS Score: 5.4

Product Status

Vendor IBM
Product Langflow OSS
Versions
  • affected from 1.0.0 to 1.12.3 (incl.)

Solutions

IBM strongly recommends addressing the vulnerability now by upgrading Langflow OSS to version 1.12.4. https://pypi.org/project/langflow/1.12.4/

For Langflow OSS versions 1.0.0 - 1.12.3, follow the Prepare to upgrade instructions and release-specific configuration changes https://docs.langflow.org/release-notes , including backing up your existing installation, then follow the Langflow OSS installation instructions https://docs.langflow.org/get-started-installation to install version 1.12.4 and test your flows.

References

Problem Types

  • CWE-918 Server-Side Request Forgery (SSRF) CWE