CVE-2026-104647 PUBLISHED

weMail <= 2.1.6 - Editor+ Incorrect Authorization via User::can()

Assigner: WPScan
Reserved: 02.10.2026 Published: 03.11.2026 Updated: 03.11.2026

The weMail WordPress plugin through 2.1.6 does not correctly verify user capabilities in its REST API permission checks, treating any user whose role is in the weMail WordPress plugin through 2.1.6's allowed-roles list (Editor and above by default) as authorised for every action, which allows such users to perform administrator-level actions including enumerating all registered users with their email addresses and modifying the weMail WordPress plugin through 2.1.6's own access-control configuration.

Product Status

Vendor Unknown
Product weMail
Versions Default: unknown
  • affected from 0 to 2.1.6 (incl.)

Credits

  • Dishant Modi finder
  • WPScan coordinator

References

Problem Types

  • CWE-863 Incorrect Authorization CWE