CVE-2026-104738 PUBLISHED

Advanced Form Integration <= 2.10.2 - Unauthenticated PHP Object Injection via $_POST Parameters

Assigner: Wordfence
Reserved: 02.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The Advanced Form Integration — Connect Forms to 300+ Apps plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.10.2 via deserialization of untrusted input . This makes it possible for unauthenticated attackers to inject a PHP Object. No known POP chain is present in the vulnerable software, which means this vulnerability has no impact unless another plugin or theme containing a POP chain is installed on the site. If a POP chain is present via an additional plugin or theme installed on the target system, it may allow the attacker to perform actions like delete arbitrary files, retrieve sensitive data, or execute code depending on the POP chain present. Exploitation requires that an administrator has previously configured at least one active NexForms integration (status=1) in the plugin's database table; in the free tier, only POST parameter keys containing the substrings 'name', 'email', 'first', or 'last' are routed to the vulnerable normalizer.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS Score: 8.1

Product Status

Vendor nasirahmed
Product Advanced Form Integration — Connect Forms to 300+ Apps
Versions Default: unaffected
  • affected from 0 to 2.10.2 (incl.)

Credits

  • Wordfence PRISM finder

References

Problem Types

  • CWE-502 Deserialization of Untrusted Data CWE