CVE-2026-104768 PUBLISHED

AutomatorWP <= 6.0.4 - Unauthenticated Privilege Escalation to Insufficient Role Validation in Anonymous Automation 'Role' Option

Assigner: Wordfence
Reserved: 02.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The AutomatorWP – No-Code Workflow Automation, Integration & Webhooks Plugin, now with AI plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.0.4. This is due to missing privilege-ceiling validation in the create_user() function within the anonymous-user action (and equally in the Create User and Add/Change Role WordPress-integration actions), which verify only that the submitted role exists via automatorwp_get_editable_roles() without confirming the role falls at or below the acting context's privilege level — allowing attacker-controlled trigger tag data (e.g., a {comment_author} tag bound to the Role option) to supply any role, including administrator, unchallenged. This makes it possible for unauthenticated attackers to create a new administrator-role account tied to an attacker-controlled email address, receiving the generated password via WordPress's new-user notification email and thereby gaining full administrative access to the site. Exploitation requires the site to have an anonymous automation configured with the Role option bound to a dynamic trigger tag such as {comment_author}, and is triggered when a site administrator performs the routine action of approving a comment — an action that provides no in-UI indication that it will mint a new privileged account from the comment author field.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS Score: 7.5

Product Status

Vendor rubengc
Product AutomatorWP – No-Code Workflow Automation, Integration & Webhooks Plugin, now with AI
Versions Default: unaffected
  • affected from 0 to 6.0.4 (incl.)

Credits

  • John Ryan Albon finder

References

Problem Types

  • CWE-269 Improper Privilege Management CWE