CVE-2026-10511 PUBLISHED

Jupiter X Core <= 4.61.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'forget_password_link' Parameter

Assigner: Wordfence
Reserved: 01.06.2026 Published: 27.10.2026 Updated: 27.10.2026

The Jupiter X Core plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'forget_password_link' parameter in all versions up to, and including, 4.61.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor artbees
Product Jupiter X Core
Versions Default: unaffected
  • affected from 0 to 4.61.0 (incl.)

Credits

  • theviper17y finder

References

Problem Types

  • CWE-80 Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) CWE