CVE-2026-109215 PUBLISHED

LiteSpeed Cache <= 7.9.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting via VPI Image Attribute Re-Serialization

Assigner: Wordfence
Reserved: 12.10.2026 Published: 29.10.2026 Updated: 29.10.2026

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'bbp_reply_content' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires that an administrator has enabled Viewport Images (VPI) and configured a VPI filename that matches an image the attacker can embed in user-generated content — such as a bbPress topic where Subscriber-level Participants are permitted to post replies containing raw img tags.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor litespeedtech
Product LiteSpeed Cache
Versions Default: unaffected
  • affected from 0 to 7.9.1 (incl.)

Credits

  • Adrien Brunner finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE