CVE-2026-109995 PUBLISHED

Advanced Views <= 3.9.6 - Unauthenticated Stored Cross-Site Scripting via Comment Content

Assigner: Wordfence
Reserved: 13.10.2026 Published: 27.10.2026 Updated: 27.10.2026

The Advanced Views – Display Framework for Gutenberg & Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.9.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is exploitable even against pending or unapproved comments, as the plugin's get_comment() lookup applies no approval-status filter, meaning a payload executes for any visitor loading an avf-layout block bound to the attacker's comment ID before the comment is ever reviewed.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 7.2

Product Status

Vendor wplakeorg
Product Advanced Views – Display Framework – Gutenberg/Elementor/Shortcode
Versions Default: unaffected
  • affected from 0 to 3.9.6 (incl.)

Credits

  • nguyen viet tin finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE