CVE-2026-110193 PUBLISHED

Langflow OSS is affected by multiple vulnerabilities

Assigner: ibm
Reserved: 13.10.2026 Published: 29.10.2026 Updated: 29.10.2026

IBM Langflow OSS 1.0.0 through 1.12.8 could allow a remote attacker with a low-privileged authenticated account to cause the Agentic Assistant to generate or submit component code using these unblocked patterns, resulting in arbitrary operating system command execution on the server.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS Score: 8.8

Product Status

Vendor IBM
Product Langflow OSS
Versions
  • affected from 1.0.0 to 1.12.8 (incl.)

Solutions

Upgrade to Langflow OSS 1.13.0 or later. The latest release is available at https://github.com/langflow-ai/langflow/releases . Users deploying via pip may upgrade with: pip install langflow --upgrade. Users deploying via Docker should pull the latest tagged image.

References

Problem Types

  • CWE-94 Improper Control of Generation of Code ('Code Injection') CWE