CVE-2026-115592 PUBLISHED

WordPress OceanWP theme <= 4.2.7 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 23.10.2026 Published: 29.10.2026 Updated: 29.10.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in OceanWP OceanWP oceanwp allows Reflected XSS.This issue affects OceanWP: from n/a through 4.2.7.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 7.1

Product Status

Vendor OceanWP
Product OceanWP
Versions Default: unaffected
  • affected from 0 to 4.2.7 (incl.)

Solutions

Update the WordPress OceanWP theme to the latest available version (at least 4.2.8).

Credits

  • Intrudify | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Reflected XSS