CVE-2026-115946 PUBLISHED

XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder

Assigner: CPANSec
Reserved: 23.10.2026 Published: 31.10.2026 Updated: 31.10.2026

XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder.

Affected versions compile a bundled brotli into static archives that dependent XS modules link against at build time, rather than using the system library. The bundled copy, 1.0.7 or 1.1.0 across the range, carries the decoder out-of-bounds write described in CVE-2026-111497. Version 1.2.1.0 updates it to brotli 1.2.1.

XS::libbrotli has no Perl interface, so the decoder is reached through any dependent module that decompresses untrusted data with it. An attacker supplying a crafted brotli stream can corrupt decoder state, disclose memory, crash the process, or potentially execute arbitrary code. Upgrading the system brotli does not remediate this.

Product Status

Package Collection https://cpan.org/modules
Package Name XS-libbrotli
Versions Default: unaffected
  • affected from 0 to 1.2.1.0 (excl.)

Solutions

Upgrade to XS-libbrotli 1.2.1.0 or later and reinstall every XS module built against it.

References

Problem Types

  • CWE-1395 Dependency on Vulnerable Third-Party Component CWE