CVE-2026-115955 PUBLISHED

WordPress Advanced Post Block - Post Grid for WordPress block editor plugin <= 2.5.1 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 24.10.2026 Published: 26.10.2026 Updated: 26.10.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Advanced Post Block - Post Grid for WordPress block editor advanced-post-block allows Stored XSS.This issue affects Advanced Post Block - Post Grid for WordPress block editor: from n/a through 2.5.1.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor bPlugins
Product Advanced Post Block - Post Grid for WordPress block editor
Versions Default: unaffected
  • affected from 0 to 2.5.1 (incl.)

Solutions

Update the WordPress Advanced Post Block - Post Grid for WordPress block editor plugin to the latest available version (at least 2.5.2).

Credits

  • V1T | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS