CVE-2026-116124 PUBLISHED

GNOME libgsf OLE2 gsf-infile-msole.c ole_info_read_metabat heap-based overflow

Assigner: VulDB
Reserved: 25.10.2026 Published: 26.10.2026 Updated: 26.10.2026

A security vulnerability has been detected in GNOME libgsf up to 1.14.60. The impacted element is the function ole_info_read_metabat of the file gsf/gsf-infile-msole.c of the component OLE2 Parser. The manipulation leads to heap-based buffer overflow. The attack can be initiated remotely. The identifier of the patch is a8e25560b74f84c3f86df6ca0ac59195fa5af68a. It is recommended to apply a patch to fix this issue.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X
CVSS Score: 5.3

Product Status

Vendor GNOME
Product libgsf
Versions
  • Version 1.14.0 is affected
  • Version 1.14.1 is affected
  • Version 1.14.2 is affected
  • Version 1.14.3 is affected
  • Version 1.14.4 is affected
  • Version 1.14.5 is affected
  • Version 1.14.6 is affected
  • Version 1.14.7 is affected
  • Version 1.14.8 is affected
  • Version 1.14.9 is affected
  • Version 1.14.10 is affected
  • Version 1.14.11 is affected
  • Version 1.14.12 is affected
  • Version 1.14.13 is affected
  • Version 1.14.14 is affected
  • Version 1.14.15 is affected
  • Version 1.14.16 is affected
  • Version 1.14.17 is affected
  • Version 1.14.18 is affected
  • Version 1.14.19 is affected
  • Version 1.14.20 is affected
  • Version 1.14.21 is affected
  • Version 1.14.22 is affected
  • Version 1.14.23 is affected
  • Version 1.14.24 is affected
  • Version 1.14.25 is affected
  • Version 1.14.26 is affected
  • Version 1.14.27 is affected
  • Version 1.14.28 is affected
  • Version 1.14.29 is affected
  • Version 1.14.30 is affected
  • Version 1.14.31 is affected
  • Version 1.14.32 is affected
  • Version 1.14.33 is affected
  • Version 1.14.34 is affected
  • Version 1.14.35 is affected
  • Version 1.14.36 is affected
  • Version 1.14.37 is affected
  • Version 1.14.38 is affected
  • Version 1.14.39 is affected
  • Version 1.14.40 is affected
  • Version 1.14.41 is affected
  • Version 1.14.42 is affected
  • Version 1.14.43 is affected
  • Version 1.14.44 is affected
  • Version 1.14.45 is affected
  • Version 1.14.46 is affected
  • Version 1.14.47 is affected
  • Version 1.14.48 is affected
  • Version 1.14.49 is affected
  • Version 1.14.50 is affected
  • Version 1.14.51 is affected
  • Version 1.14.52 is affected
  • Version 1.14.53 is affected
  • Version 1.14.54 is affected
  • Version 1.14.55 is affected
  • Version 1.14.56 is affected
  • Version 1.14.57 is affected
  • Version 1.14.58 is affected
  • Version 1.14.59 is affected
  • Version 1.14.60 is affected

Credits

  • suyuanwang (VulDB User) reporter

References

Problem Types

  • Heap-based Buffer Overflow CWE
  • Memory Corruption CWE