CVE-2026-116174 PUBLISHED

vLLM 0.22.0 before 0.24.0 Denial of Service via Rust gRPC Generate

Assigner: VulnCheck
Reserved: 25.10.2026 Published: 25.10.2026 Updated: 25.10.2026

vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC Generate and GenerateStream service that forwards unchecked prompt token IDs to EngineCore. Attackers can submit requests with out-of-vocabulary prompt.token_ids values to trigger a fatal embedding lookup failure that terminates EngineCore and leaves the server unhealthy.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS Score: 8.2

Product Status

Vendor vllm-project
Product vllm
Versions Default: unaffected
  • affected from 0.22.0 to 0.24.0 (excl.)
  • Version 0.24.0 is unaffected

Credits

  • rexpository reporter
  • jperezdealgaba coordinator

References

Problem Types

  • Improper Input Validation CWE