CVE-2026-116178 PUBLISHED

vLLM 0.20.0 before 0.30.0 DoS via /inference/v1/generate mm_placeholders

Assigner: VulnCheck
Reserved: 25.10.2026 Published: 25.10.2026 Updated: 25.10.2026

vLLM from 0.20.0 before 0.30.0 contains a denial of service vulnerability that allows remote attackers to crash the engine by sending inconsistent multimodal metadata to the disaggregated /inference/v1/generate endpoint. Attackers can replay a valid multimodal item with repeated or overlapping mm_placeholders ranges or mismatched kwargs_data and mm_hashes lists, producing a negative text span in Qwen2.5-VL position construction that terminates the engine.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS Score: 8.2

Product Status

Vendor vllm-project
Product vllm
Versions Default: unaffected
  • affected from 0.20.0 to 0.30.0 (excl.)
  • Version 0.30.0 is unaffected

Credits

  • JSGforever reporter
  • jperezdealgaba coordinator

References

Problem Types

  • Improper Input Validation CWE