CVE-2026-116537 PUBLISHED

Link Library <= 7.10.0 - Unauthenticated Stored Cross-Site Scripting via 'link_description' Parameter

Assigner: Wordfence
Reserved: 26.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The Link Library plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'link_description' parameter in all versions up to, and including, 7.10.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This exploit requires the site administrator to have enabled the non-default 'Convert [] to <> in Link Description and Notes' (use_html_tags) setting; when this option is off, the bracket-to-angle-bracket conversion never runs and the payload is never reconstructed into executable HTML.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 7.2

Product Status

Vendor jackdewey
Product Link Library
Versions Default: unaffected
  • affected from 0 to 7.10.0 (incl.)

Credits

  • Jacek Sowiński (dzaku) finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE