CVE-2026-116763 PUBLISHED

LiteSpeed Cache <= 7.9.1 - Unauthenticated Stored Cross-Site Scripting via HTML Minifier Predictable Placeholder (md5(REQUEST_TIME) + two-pass str_replace)

Assigner: Wordfence
Reserved: 26.10.2026 Published: 29.10.2026 Updated: 29.10.2026

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.9.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the HTML Minify option (O_OPTM_HTML_MIN) is enabled and a companion plugin renders stored comment content into a raw-text context such as a JSON-LD script block on the same page.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 5.4

Product Status

Vendor litespeedtech
Product LiteSpeed Cache
Versions Default: unaffected
  • affected from 0 to 7.9.1 (incl.)

Credits

  • Santh finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE