CVE-2026-118048 PUBLISHED

WP Data Access <= 5.5.89 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Autocomplete Lookup Label

Assigner: Wordfence
Reserved: 27.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The WP Data Access plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Simple Form autocomplete lookup label in versions up to, and including, 5.5.89 This is due to insufficient output escaping on the value returned by WPDA_Autocomplete::autocomplete_lookup() when it is emitted into a single-quoted HTML attribute by WPDA_Simple_Form_Item_Autocomplete::show_item() (the escape-output lint is explicitly suppressed on the echo line). This makes it possible for authenticated attackers, with Subscriber-level access and above, who are permitted to edit a lookup row through a legacy Form, to inject arbitrary web scripts in pages that will execute whenever a user — including a higher-privileged user editing a linked record that uses the autocomplete relationship — accesses the injected page.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor peterschulznl
Product WP Data Access – App Builder for Tables, Forms, Dashboards, Charts & Maps
Versions Default: unaffected
  • affected from 0 to 5.5.89 (incl.)

Credits

  • R3D finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE