CVE-2026-119070 PUBLISHED

Optimole <= 4.2.17 - Unauthenticated Stored Cross-Site Scripting via Comment Content via Backslash-Escaped Unicode in URL Replacer

Assigner: Wordfence
Reserved: 29.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.2.17 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The exploit requires the plugin to be in its normal connected state (cdn_key and cdn_secret configured) with the image replacer enabled, which is the default post-setup configuration; the stored payload bypasses all WordPress comment sanitization filters because it contains no HTML metacharacters at storage time — the characters are produced only by Optimole's own decoder at render time.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 7.2

Product Status

Vendor optimole
Product Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization
Versions Default: unaffected
  • affected from 0 to 4.2.17 (incl.)

Credits

  • crow finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE