CVE-2026-119152 PUBLISHED

Appointment Booking Plugin <= 5.7.6 - Unauthenticated Stored Cross-Site Scripting via Customer Email Field

Assigner: Wordfence
Reserved: 29.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'customer[email] (inside params)' parameter in all versions up to, and including, 5.7.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. An unauthenticated visitor can exploit this by registering as a LatePoint customer via the public booking form — receiving an active customer session with no WordPress account — and then submitting a quoted local-part email address containing an HTML payload (e.g. a tag with no spaces) that passes FILTER_VALIDATE_EMAIL but is stored and rendered unescaped.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 5.4

Product Status

Vendor latepoint
Product Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress
Versions Default: unaffected
  • affected from 0 to 5.7.6 (incl.)

Credits

  • Maciej Komorowski finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE