CVE-2026-119165 PUBLISHED

WPBakery Page Builder <= 9.0.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Post Author Display Name

Assigner: Wordfence
Reserved: 29.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name / nickname' parameter in all versions up to, and including, 9.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful execution requires that at least one public post attributed to the attacker's account be rendered through a Basic Grid using a Grid Builder template with the Post Author element configured to link to the post author; Author-level users can satisfy this precondition unassisted, while Subscribers depend on an administrator having assigned or published a post under their account.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor wpbakery
Product WPBakery Page Builder
Versions Default: unaffected
  • affected from 0 to 9.0.1 (incl.)

Credits

  • Rafie Muhammad finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE