CVE-2026-119167 PUBLISHED

TranslatePress <= 3.3.8 - Unauthenticated Stored Cross-Site Scripting via Comment Content via trp-gettext Marker Smuggling and PCRE Backtrack Bypass

Assigner: Wordfence
Reserved: 29.10.2026 Published: 07.11.2026 Updated: 07.11.2026

The TranslatePress – Translate Multilingual sites with AI Translation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 3.3.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires that at least one prior comment from the attacker's name and email pair has been approved under WordPress's default comment_previously_approved moderation setting, and that a secondary language is configured in TranslatePress.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 7.2

Product Status

Vendor cozmoslabs
Product TranslatePress – Translate Multilingual sites with AI Translation
Versions Default: unaffected
  • affected from 0 to 3.3.8 (incl.)

Credits

  • UKO finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE