CVE-2026-119507 PUBLISHED

WordPress NotificationX plugin <= 3.3.6 - Content Injection vulnerability

Assigner: Patchstack
Reserved: 30.10.2026 Published: 07.11.2026 Updated: 07.11.2026

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in WPDeveloper NotificationX notificationx allows Code Injection.This issue affects NotificationX: from n/a through 3.3.6.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
CVSS Score: 5.3

Product Status

Vendor WPDeveloper
Product NotificationX
Versions Default: unaffected
  • affected from 0 to 3.3.6 (incl.)

Solutions

Update the WordPress NotificationX plugin to the latest available version (at least 3.3.7).

Credits

  • braintx | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) CWE

Impacts

  • Code Injection