CVE-2026-119520 PUBLISHED

WordPress Spectra plugin <= 2.20.4 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 30.10.2026 Published: 07.11.2026 Updated: 07.11.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Brainstorm Force Spectra ultimate-addons-for-gutenberg allows Stored XSS.This issue affects Spectra: from n/a through 2.20.4.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor Brainstorm Force
Product Spectra
Versions Default: unaffected
  • affected from 0 to 2.20.4 (incl.)

Solutions

Update the WordPress Spectra plugin to the latest available version (at least 2.20.5).

Credits

  • Deva Parekh | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS