CVE-2026-119747 PUBLISHED

GetPaid WordPress Plugin < 2.8.63 Incorrect Authorization via REST API

Assigner: VulnCheck
Reserved: 30.10.2026 Published: 04.11.2026 Updated: 04.11.2026

The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization vulnerability where the check_post_permissions() method in includes/api/class-getpaid-rest-posts-controller.php maps REST operations to generic WordPress post capabilities instead of enforcing the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can exploit this flaw to list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS Score: 7.1

Product Status

Vendor AyeCode Ltd
Product Payment forms, Buy now buttons, and Invoicing System | GetPaid
Versions Default: unaffected
  • affected from 0 to 2.8.63 (excl.)

Credits

  • Idan Malihi reporter

References

Problem Types

  • Incorrect Authorization CWE