CVE-2026-119748 PUBLISHED

GetPaid WordPress Plugin < 2.8.63 Authorization Bypass via maybe_use_invoice

Assigner: VulnCheck
Reserved: 30.10.2026 Published: 04.11.2026 Updated: 04.11.2026

The GetPaid plugin for WordPress before 2.8.63 contains an authorization bypass vulnerability that allows unauthenticated attackers to access and manipulate another user's invoice by supplying its ID through the maybe_use_invoice parameter in process_invoice(), bypassing the ownership and key checks performed by is_authorized_to_pay(). Attackers can submit a known pending invoice ID via maybe_use_invoice to read checkout pricing details and initiate a checkout workflow, resulting in an unauthorized state change of the invoice to on-hold.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N
CVSS Score: 6.9

Product Status

Vendor AyeCode Ltd
Product Payment forms, Buy now buttons, and Invoicing System | GetPaid
Versions Default: unaffected
  • affected from 0 to 2.8.63 (excl.)

Credits

  • Idan Malihi reporter

References

Problem Types

  • Authorization Bypass Through User-Controlled Key CWE