CVE-2026-119922 PUBLISHED

Babelfish for PostgreSQL Privilege Escalation

Assigner: AMZN
Reserved: 30.10.2026 Published: 03.11.2026 Updated: 03.11.2026

Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend you upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS Score: 8.7

Product Status

Vendor AWS
Product babelfish-for-postgresql
Versions Default: unaffected
  • affected from 1.2 to 1.5 (incl.)
  • affected from 2.1 to 2.15 (incl.)
  • affected from 3.1 to 3.12 (incl.)
  • affected from 4.0 to 4.8 (incl.)
  • affected from 5.1 to 5.4 (incl.)

References

Problem Types

  • CWE-266 Incorrect privilege assignment CWE

Impacts

  • CAPEC-233 Privilege Escalation