CVE-2026-119924 PUBLISHED

Out-of-Bounds Read in Babelfish for PostgreSQL TDS RPC Procedure-Name Parser

Assigner: AMZN
Reserved: 30.10.2026 Published: 06.11.2026 Updated: 06.11.2026

An out-of-bounds read in the TDS RPC procedure-name parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote authenticated users to read adjacent process memory or cause a denial of service via a malformed TDS RPC request to the TDS port (default 1433).

To remediate this issue, we recommend users upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later. As a workaround, restrict network access to the TDS port (default 1433). Customers using Amazon Aurora PostgreSQL with Babelfish should upgrade their cluster to Aurora PostgreSQL 13.9.16 (1.5.5), 13.23.3 (1.17.2), 14.6.16 (2.3.5), 14.17.8 (2.12.4), 14.18.6 (2.13.3), 14.19.5 (2.14.2), 14.20.5 (2.15.2), 14.22.3 (2.16.1), 14.23.1 (2.17.0), 15.10.8 (3.8.4), 15.12.8 (3.9.4), 15.13.6 (3.10.3), 15.14.5 (3.11.2), 15.15.5 (3.12.2), 15.17.3 (3.13.1), 15.18.1 (3.14.0), 16.8.8 (4.5.5), 16.9.6 (4.6.3), 16.10.5 (4.7.2), 16.11.5 (4.8.2), 16.13.3 (4.9.1), 16.14.1 (4.10.0), 17.4.8 (5.1.4), 17.5.6 (5.2.3), 17.6.5 (5.3.2), 17.7.5 (5.4.2), 17.9.3 (5.5.1), 17.10.1 (5.6.0), 18.3.4 (6.0.2), 18.4.1 (6.1.0) or later, and apply any pending maintenance to ensure they are on the latest patch.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS Score: 7.2

Product Status

Vendor AWS
Product babelfish-for-postgresql
Versions Default: unaffected
  • affected from 1.0 to 1.5 (incl.)
  • affected from 2.1 to 2.15 (incl.)
  • affected from 3.1 to 3.12 (incl.)
  • affected from 4.0 to 4.8 (incl.)
  • affected from 5.1 to 5.4 (incl.)
Vendor Amazon
Product Amazon Aurora PostgreSQL with Babelfish
Versions Default: unaffected
  • affected from 1.0.0 to 1.5.5 (excl.)
  • affected from 1.6.0 to 1.17.2 (excl.)
  • affected from 2.0.0 to 2.3.5 (excl.)
  • affected from 2.4.0 to 2.12.4 (excl.)
  • affected from 2.13.0 to 2.13.3 (excl.)
  • affected from 2.14.0 to 2.14.2 (excl.)
  • affected from 2.15.0 to 2.15.2 (excl.)
  • affected from 2.16.0 to 2.16.1 (excl.)
  • affected from 3.0.0 to 3.8.4 (excl.)
  • affected from 3.9.0 to 3.9.4 (excl.)
  • affected from 3.10.0 to 3.10.3 (excl.)
  • affected from 3.11.0 to 3.11.2 (excl.)
  • affected from 3.12.0 to 3.12.2 (excl.)
  • affected from 3.13.0 to 3.13.1 (excl.)
  • affected from 4.0.0 to 4.5.5 (excl.)
  • affected from 4.6.0 to 4.6.3 (excl.)
  • affected from 4.7.0 to 4.7.2 (excl.)
  • affected from 4.8.0 to 4.8.2 (excl.)
  • affected from 4.9.0 to 4.9.1 (excl.)
  • affected from 5.0.0 to 5.1.4 (excl.)
  • affected from 5.2.0 to 5.2.3 (excl.)
  • affected from 5.3.0 to 5.3.2 (excl.)
  • affected from 5.4.0 to 5.4.2 (excl.)
  • Version 5.5.0 is affected
  • affected from 6.0.0 to 6.0.2 (excl.)

References

Problem Types

  • CWE-125 Out-of-bounds read CWE

Impacts

  • CAPEC-540 Overread Buffers