CVE-2026-120533 PUBLISHED

Redux Framework <= 4.5.16 - Authenticated (Custom+) Stored Cross-Site Scripting via theme_opts Parameter via User Profile

Assigner: Wordfence
Reserved: 02.11.2026 Published: 05.11.2026 Updated: 05.11.2026

The Redux Framework plugin for WordPress is vulnerable to Stored Cross-Site Scripting via theme_opts Parameter via User Profile in all versions up to, and including, 4.5.16 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires the host theme to have registered a Redux field of a CSS-emitting type (such as link_color, border, or typography) with an output CSS selector, as only the field types 'spinner', 'slider', 'color', and 'date' receive per-type value validation that would block the entity-encoded payload.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor davidanderson
Product Redux Framework
Versions Default: unaffected
  • affected from 0 to 4.5.16 (incl.)

Credits

  • Maciej Komorowski finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE