CVE-2026-120537 PUBLISHED

TranslatePress <= 3.3.8 - Unauthenticated Stored Cross-Site Scripting via Comment Attribute via trp-ajax.php Dictionary Endpoint

Assigner: Wordfence
Reserved: 02.11.2026 Published: 07.11.2026 Updated: 07.11.2026

The TranslatePress – Translate Multilingual sites with AI Translation plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment (storage); originals / language / original_language (exfiltration from endpoint)' parameter in all versions up to, and including, 3.3.8 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 7.2

Product Status

Vendor cozmoslabs
Product TranslatePress – Translate Multilingual sites with AI Translation
Versions Default: unaffected
  • affected from 0 to 3.3.8 (incl.)

Credits

  • Klaudia Gackowska finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE