CVE-2026-120563 PUBLISHED

WPML Multilingual & Multicurrency for WooCommerce <= 5.5.7 - Authenticated (Shop Manager+) SQL Injection via Exchange Rate Field

Assigner: Wordfence
Reserved: 02.11.2026 Published: 03.11.2026 Updated: 03.11.2026

The WooCommerce Multilingual & Multicurrency with WPML plugin for WordPress is vulnerable to SQL Injection in all versions up to, and including, 5.5.7. This is due to insufficient input validation on the currency exchange rate parameter in the save_currency() AJAX handler, which lacks capability checks and allows subscriber-level users to store malicious SQL payloads that are later concatenated directly into ORDER BY clauses without proper sanitization. This makes it possible for authenticated attackers, with Shop Manager-level access and above, to append additional SQL queries to extract sensitive information from the database.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
CVSS Score: 4.9

Product Status

Vendor amirhelzer
Product WPML Multilingual & Multicurrency for WooCommerce
Versions Default: unaffected
  • affected from 0 to 5.5.7 (incl.)

Credits

  • Muni Nitish Kumar Yaddala (Stranger825) finder

References

Problem Types

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command CWE