CVE-2026-120575 PUBLISHED

Photo Engine (Media Organizer & Lightroom) <= 6.5.7 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Collection Name

Assigner: Wordfence
Reserved: 02.11.2026 Published: 03.11.2026 Updated: 03.11.2026

The Photo Engine (Media Organizer & Lightroom) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'hierarchy[].name' parameter in all versions up to, and including, 6.5.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable by Subscribers because the /?wplr-sync-api endpoint authenticates solely via wplr_auth_token usermeta with no capability check, and the current user's token is exposed on every admin page via localized script data due to a commented-out screen-condition guard.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor tigroumeow
Product Photo Engine (Media Organizer & Lightroom)
Versions Default: unaffected
  • affected from 0 to 6.5.7 (incl.)

Credits

  • Wordfence PRISM finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE