CVE-2026-120677 PUBLISHED

Optimole <= 4.2.18 - Unauthenticated Stored Cross-Site Scripting via Comment Content

Assigner: Wordfence
Reserved: 02.11.2026 Published: 07.11.2026 Updated: 07.11.2026

The Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.2.18 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the comment to be approved by an administrator and for the affected post to contain at least one iframe or video element (e.g., a core Video block), which is sufficient under default plugin settings where video lazy loading is enabled.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 7.2

Product Status

Vendor optimole
Product Optimole – Optimize Images | Convert WebP & AVIF | CDN & Lazy Load | Image Optimization
Versions Default: unaffected
  • affected from 0 to 4.2.18 (incl.)

Credits

  • Kohav finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE