CVE-2026-120843 PUBLISHED

WordPress Posts Table with Search & Sort plugin <= 1.4.14 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 03.11.2026 Published: 03.11.2026 Updated: 03.11.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Barn2 Plugins Posts Table with Search & Sort posts-data-table allows Stored XSS.This issue affects Posts Table with Search & Sort: from n/a through 1.4.14.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor Barn2 Plugins
Product Posts Table with Search & Sort
Versions Default: unaffected
  • affected from 0 to 1.4.14 (incl.)

Solutions

Update the WordPress Posts Table with Search & Sort plugin to the latest available version (at least 1.4.15).

Credits

  • johska | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS