CVE-2026-120845 PUBLISHED

WordPress Smush Image Compression and Optimization plugin <= 4.3.5 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 03.11.2026 Published: 06.11.2026 Updated: 06.11.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WPMU DEV Smush Image Compression and Optimization wp-smushit allows Stored XSS.This issue affects Smush Image Compression and Optimization: from n/a through 4.3.5.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor WPMU DEV
Product Smush Image Compression and Optimization
Versions Default: unaffected
  • affected from 0 to 4.3.5 (incl.)

Solutions

Update the WordPress Smush Image Compression and Optimization plugin to the latest available version (at least 4.3.6).

Credits

  • dzaku | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS