CVE-2026-121509 PUBLISHED

Headless CMS Plugin REST API post get_required_post_data information disclosure

Assigner: VulDB
Reserved: 03.11.2026 Published: 03.11.2026 Updated: 03.11.2026

A security flaw has been discovered in Headless CMS Plugin up to 2.0.4 on WordPress. This affects the function get_required_post_data of the file /wp-json/rae/v1/post of the component REST API. The manipulation of the argument post_id/post_slug results in information disclosure. The attack may be launched remotely. The exploit has been released to the public and may be used for attacks. The vendor was contacted early about this disclosure but did not respond in any way.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P
CVSS Score: 6.9

Product Status

Vendor n/a
Product Headless CMS Plugin
Versions
  • Version 2.0.0 is affected
  • Version 2.0.1 is affected
  • Version 2.0.2 is affected
  • Version 2.0.3 is affected
  • Version 2.0.4 is affected

Credits

  • Rony Ahmed (VulDB User) reporter
  • VulDB CNA Team coordinator

References

Problem Types

  • Information Disclosure CWE
  • Improper Access Controls CWE