CVE-2026-121515 PUBLISHED

FV Flowplayer Video Player <= 7.5.56.7212 - Unauthenticated Stored Cross-Site Scripting via Comment Content

Assigner: Wordfence
Reserved: 03.11.2026 Published: 07.11.2026 Updated: 07.11.2026

The FV Flowplayer Video Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 7.5.56.7212 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the 'Parse Vimeo and YouTube links' option to be enabled, and the injected comment must be approved before the script executes for site visitors.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 5.4

Product Status

Vendor foliovision
Product FV Flowplayer Video Player
Versions Default: unaffected
  • affected from 0 to 7.5.56.7212 (incl.)

Credits

  • theviper17y finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE