CVE-2026-121519 PUBLISHED

Social Slider Feed <= 2.3.8 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'slidespeed' Parameter

Assigner: Wordfence
Reserved: 03.11.2026 Published: 07.11.2026 Updated: 07.11.2026

The Social Slider Feed – Social Media Feed & Gallery Widgets plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'slidespeed' parameter in all versions up to, and including, 2.3.8 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The missing current_user_can() check in the Factory framework's connect() dispatcher allows Subscriber-level users to bypass the manage_options capability gate and both harvest a valid wis_edit_feed nonce and overwrite any feed's slidespeed setting, after which the stored payload fires on every public pageview embedding the feed shortcode.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 6.4

Product Status

Vendor themeisle
Product Social Slider Feed – Social Media Feed & Gallery Widgets
Versions Default: unaffected
  • affected from 0 to 2.3.8 (incl.)

Credits

  • Kuba finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE