CVE-2026-121652 PUBLISHED

Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering

Assigner: AMZN
Reserved: 03.11.2026 Published: 03.11.2026 Updated: 03.11.2026

Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl.

To remediate this issue, users should upgrade to 4.0.3 or later.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
CVSS Score: 4.8

Product Status

Vendor AWS
Product maplibre-gl-js-amplify
Versions Default: unaffected
  • affected from 0 to 4.0.3 (excl.)

References

Problem Types

  • CWE-79 Improper neutralization of input during web page generation ('cross-site scripting') CWE

Impacts

  • CAPEC-592 Stored XSS