CVE-2026-121762 PUBLISHED

WordPress PowerPress Podcasting plugin <= 11.18.0 - Cross Site Request Forgery (CSRF) vulnerability

Assigner: Patchstack
Reserved: 04.11.2026 Published: 07.11.2026 Updated: 07.11.2026

Cross-Site Request Forgery (CSRF) vulnerability in Blubrry Podcasting PowerPress Podcasting powerpress allows Cross Site Request Forgery.This issue affects PowerPress Podcasting: from n/a through 11.18.0.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS Score: 8.8

Product Status

Vendor Blubrry Podcasting
Product PowerPress Podcasting
Versions Default: unaffected
  • affected from 0 to 11.18.0 (incl.)

Solutions

Update the WordPress PowerPress Podcasting plugin to the latest available version (at least 11.18.2).

Credits

  • AndrewN | Patchstack Bug Bounty Program finder

References

Problem Types

  • Cross-Site Request Forgery (CSRF) CWE

Impacts

  • Cross Site Request Forgery