CVE-2026-121765 PUBLISHED

WordPress TranslatePress plugin <= 3.3.8 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 04.11.2026 Published: 07.11.2026 Updated: 07.11.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Cozmoslabs TranslatePress translatepress-multilingual allows Stored XSS.This issue affects TranslatePress: from n/a through 3.3.8.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 7.1

Product Status

Vendor Cozmoslabs
Product TranslatePress
Versions Default: unaffected
  • affected from 0 to 3.3.8 (incl.)

Solutions

Update the WordPress TranslatePress plugin to the latest available version (at least 3.3.9).

Credits

  • AndrewN | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS