CVE-2026-121768 PUBLISHED

WordPress Contact Form 7 &#8211; Post Fields plugin <= 2.6.0 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 04.11.2026 Published: 07.11.2026 Updated: 07.11.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Markus Wiesenhofer Contact Form 7 – Post Fields cf7-post-fields allows Stored XSS.This issue affects Contact Form 7 – Post Fields: from n/a through 2.6.0.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor Markus Wiesenhofer
Product Contact Form 7 &#8211; Post Fields
Versions Default: unaffected
  • affected from 0 to 2.6.0 (incl.)

Solutions

Update the WordPress Contact Form 7 – Post Fields plugin to the latest available version (at least 2.7.1).

Credits

  • cazy | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS