CVE-2026-123418 PUBLISHED

Church Admin <= 5.1.7 - Unauthenticated Stored Cross-Site Scripting via 'lat' Parameter

Assigner: Wordfence
Reserved: 05.11.2026 Published: 07.11.2026 Updated: 07.11.2026

The Church Admin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'lat' parameter in all versions up to, and including, 5.1.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when a Google Maps API key has been configured in Church Admin settings, as the vulnerable sink is only reached when that option is present.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
CVSS Score: 7.2

Product Status

Vendor andy_moyle
Product Church Admin
Versions Default: unaffected
  • affected from 0 to 5.1.7 (incl.)

Credits

  • Shinya Murakami (4n86rakam1) finder

References

Problem Types

  • CWE-79 Improper Neutralization of Input During Web Page Generation CWE