CVE-2026-123542 PUBLISHED

OpenAM before 16.1.4 PKCE Bypass in OAuth 2.0 Device Authorization Flow

Assigner: VulnCheck
Reserved: 06.11.2026 Published: 08.11.2026 Updated: 08.11.2026

OpenAM before 16.1.4 fails to enforce PKCE in the OAuth 2.0 device authorization flow, never validating the code verifier when device codes are exchanged for tokens. Attackers who obtain an approved device code from client logs or shared device storage can redeem it for access and ID tokens to impersonate the user.

Metrics

CVSS Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS Score: 7.6

Product Status

Vendor OpenIdentityPlatform
Product OpenAM
Versions Default: unaffected
  • affected from 0 to 16.1.4 (excl.)
  • Version 16.1.4 is unaffected

Credits

  • manus-pi reporter
  • vharseko remediation developer
  • maximthomas remediation reviewer
  • tsujiguchitky remediation reviewer
  • manus-use reporter

References

Problem Types

  • Improperly Implemented Security Check for Standard CWE