CVE-2026-42694 PUBLISHED

WordPress Kirki plugin <= 6.4.0 - Content Injection vulnerability

Assigner: Patchstack
Reserved: 29.04.2026 Published: 29.10.2026 Updated: 29.10.2026

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Themeum Kirki kirki allows Code Injection.This issue affects Kirki: from n/a through 6.4.0.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVSS Score: 4.3

Product Status

Vendor Themeum
Product Kirki
Versions Default: unaffected
  • affected from 0 to 6.4.0 (incl.)

Solutions

Update the WordPress Kirki plugin to the latest available version (at least 6.4.1).

Credits

  • nh4tvd | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) CWE

Impacts

  • Code Injection