CVE-2026-48195 PUBLISHED

WordPress PDF Poster plugin <= 2.6.1 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 21.05.2026 Published: 29.10.2026 Updated: 29.10.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins PDF Poster pdf-poster allows Stored XSS.This issue affects PDF Poster: from n/a through 2.6.1.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor bPlugins
Product PDF Poster
Versions Default: unaffected
  • affected from 0 to 2.6.1 (incl.)

Solutions

Update the WordPress PDF Poster plugin to the latest available version (at least 2.6.2).

Credits

  • mroccon | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS