CVE-2026-52709 PUBLISHED

WordPress Video Gallery Block plugin <= 1.6.0 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 08.06.2026 Published: 29.10.2026 Updated: 29.10.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in bPlugins Video Gallery Block video-gallery-block allows Stored XSS.This issue affects Video Gallery Block: from n/a through 1.6.0.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 6.5

Product Status

Vendor bPlugins
Product Video Gallery Block
Versions Default: unaffected
  • affected from 0 to 1.6.0 (incl.)

Solutions

Update the WordPress Video Gallery Block plugin to the latest available version (at least 1.7.0).

Credits

  • Harry Nguyen | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Stored XSS