CVE-2026-54851 PUBLISHED

WordPress Contact Form by WPForms plugin <= 2.0.3 - Cross Site Scripting (XSS) vulnerability

Assigner: Patchstack
Reserved: 16.06.2026 Published: 04.11.2026 Updated: 04.11.2026

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Awesomemotive Contact Form by WPForms wpforms-lite allows Reflected XSS.This issue affects Contact Form by WPForms: from n/a through 2.0.3.

Metrics

CVSS Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
CVSS Score: 7.1

Product Status

Vendor Awesomemotive
Product Contact Form by WPForms
Versions Default: unaffected
  • affected from 0 to 2.0.3 (incl.)

Solutions

Update the WordPress Contact Form by WPForms plugin to the latest available version (at least 2.0.3.1).

Credits

  • jydae | Patchstack Bug Bounty Program finder

References

Problem Types

  • Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') CWE

Impacts

  • Reflected XSS